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DAY 2 : Introduction to AT 
Commands
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Webinar Logistics

• Turn on your system sound to hear the streaming presentation.

• If you have technical problems, click “Help” or submit a question 
asking for assistance.

• Participate in ‘Attendee Chat’ by maximizing the chat widget in your 
dock.
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Dr. Don Wilcher
Visit ‘Lecturer Profile’ in your console for more details.
LinkedIn Page:
https://www.linkedin.com/in/dr-don-wilcher-ed-d-mseit-ee-
ceta-2735151/

Patreon Page:
https://www.patreon.com/c/DrDon683
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Course Kit and Materials

Raspberry Pi 4 Single Board Computer USB-C Cable

Elecrow Crowtail Collision Sensor

Elecrow LR1302 LoRaWAN Pi Hat

Elecrow Crowtail LED 2.0

Elecrow LR1262 Node Board

LR1302 Gateway 
Module
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Research Perspective

• “LoRaWAN is one of the promising technologies of the Low Power 
Wide Arena Network (LPWAN) that provides communication with 
low power, low cost, long-range, and low data rate (Rahman et al., 
2020).”
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Agenda:
• What are AT Commands?
• Examples of AT Commands
• LR1262 Node Board AT Commands
• Lab: Exploring AT Commands with the LR1262 Node Board
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What are AT Commands?

• AT commands are commonly used in LoRaWAN technology 
to interact with and configure: 

a) LoRaWAN modules
b) or gateways 

• These commands provide a simple text-based interface for 
users to manage the LoRaWAN stack:

a) configure device parameters
b) control communication with the network.
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What are AT Commands?. . .

1. Roles of AT Commands in LoRaWAN Technology
• Device Initialization and Configuration:

a) Join the LoRaWAN Network: AT commands set up the 
device to join a LoRaWAN network using either OTAA 
(Over-the-Air Activation) or ABP (Activation by 
Personalization).

• Set Device Credentials: 
Configure keys like [DevEUI], [AppEUI], and [AppKey] for 
secure communication. 
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Question 1

What AT Commands are commonly used?
a) LoRaWANE modules and Gateways

b) LoRa modules and Gateways
c) LoRaWAN modules and Gateways
d) none of the above
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What are AT Commands?. . .

2. Radio Communication Settings
• Frequency Configuration: Set the frequency band based on 

the region (e.g., EU868, US915).
• Spreading Factor (SF) and Data Rate (DR): Optimize 

communication range and data rate.
• Power Settings: Configure transmission power for efficient 

communication.
3. Data Transmission and Reception

Send Uplink Data: Transmit sensor data or commands to the 
LoRaWAN network.
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What are AT Commands?. . .

2. Radio Communication Settings
• Frequency Configuration: Set the frequency band based on 

the region (e.g., EU868, US915).
• Spreading Factor (SF) and Data Rate (DR): Optimize 

communication range and data rate.
• Power Settings: Configure transmission power for efficient 

communication.
3. Data Transmission and Reception

Send Uplink Data: Transmit sensor data or commands to the 
LoRaWAN network.
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What are AT Commands?. . .

Receive Downlink Data: Handle messages or commands from 
the LoRaWAN network.

4. Network Management
Check Network Status: Query the connection status of the 
device.

• Enable/Disable Adaptive Data Rate (ADR): Ensure the 
device dynamically adjusts its data rate and power for 
optimal performance.
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Question 2

Which LoRaWAN frequency is used in the US?
a) 345 MHz
b) 433 MHz
c) 868 MHz
d) 915 MHz
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What are AT Commands?. . .

5. Diagnostics and Debugging
• Signal Quality: Check the signal strength (RSSI) and signal-to-

noise ratio (SNR) for network diagnostics.
• Error Handling: Retrieve error codes for debugging issues.

6. Power Management
• Sleep/Wake Up: Put the device into low-power mode to 

conserve energy.
• Battery Monitoring: Check the device's battery level (if 

supported).
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What are AT Commands?. . .

7. Over-the-Air Updates (OTA)
Some LoRaWAN modules support AT commands for initiating 
firmware updates or configuration changes over the air.
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What are AT Commands?. . .

Why AT Commands are Valuable in LoRaWAN Technology?
• Ease of Use: AT commands abstract the complexity of 

LoRaWAN protocols, making them accessible for 
developers and integrators.

• Modularity: They allow microcontrollers or host systems 
to communicate with LoRaWAN modules using simple 
serial commands, enabling integration into diverse 
applications.

• Flexibility: AT commands can handle everything from 
basic setup to advanced features like data encryption 
and adaptive data rate.
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What are AT Commands?. . .

By simplifying the interaction with LoRaWAN modules, AT 
commands make it easier to develop and deploy IoT 
applications in 

a) smart cities
b) agriculture
c) healthcare

d) industrial automation.
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Question 3

Which statement is correct?
a) AT Commands complicate the interaction with 

LoRaWAN modules.
b) AT Commands simplify the interaction with 

LoRaWAN modules.
c) AT Commands allow interaction with LoRA

modules.
d) none of the above



Sponsored By

19

Examples of AT Commands?

The following examples illustrate some of the AT Commands for 
LoRaWAN devices.

Join LoRaWAN Over-the-Air Activation:
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Examples of AT Commands?. . .

Set Device Credentials:

Power Settings:
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Examples of AT Commands?. . .

Frequency Configuration:           Spreading Factor (SF) and Data Rate (DR):
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Examples of AT Commands?. . .

Send Uplink Data:                        Receive Downlink Data:
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Question 4

What is LWOTTA?
a) LoRaWANE Over-the-Air Activation
b) LoRaWEN Over-the-Air Activation
c) LoRaWAN Over-the-Air Activation
d) none of the above
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LR1262 Node Board AT Commands

Like the generic AT Commands presented, there are specific 
ones for the LR1262 Node Board. These commands align with 
the field of the Internet of Things. These AT commands allow the 
following tasks to be performed on the board.

a) configuration
b) operation
c) data sending and receiving
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LR1262 Node Board AT Commands. . .

https://www.elecrow.co
m/wiki/LR1262_LoRaW
AN_AT_Command_Des
cription.html

LR1262 Node Board AT 
Command Description 
Document found here!

LR1262 Node Board AT Command Syntax
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LR1262 Node Board AT Commands. . .

LR1262 Node Board Example AT Commands
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LR1262 Node Board AT Commands. . .

LR1262 Node Board Example AT Commands
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Lab: Exploring AT Commands with the LR1262 
Node Board 
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Participant Learning Objectives:
• Participants will learn to set up the LR1262 Node Board.
• Participants will learn to test and program the LR1262 Node 

Board using the Arduino IDE.
• Participants will learn to verify the operation of the LR1262 

Node Board with AT Command LED Indicator code.

Lab: Exploring AT Commands with the LR1262 
Node Board. . . 



Sponsored By

30

Concept Diagram

Image: ChatGPT

Lab: Exploring AT Commands with the LR1262 
Node Board. . . 
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Programming the LR1262 Node Board
1. Install the Arduino IDE:

If you haven't already, download and install the Arduino IDE from the official website.

2. Add the LR1262 Board Package:
• Open the Arduino IDE.
• Go to File > Preferences.
• In the "Additional Boards Manager URLs" field, add the following 

URL: https://github.com/earlephilhower/arduino-
pico/releases/download/global/package_rp2040_index.json (This URL is for the RP2040, which 
is often associated with similar LoRa boards like the LR1262).

• Click "OK.
3. Install the Board Package:

• Go to Tools > Board > Boards Manager.
• Search for "RP2040" or a similar term related to the LR1262 board.
• Install the board package,but avoid the latest version. It is recommended to choose version 

2.6.0.

Lab: Exploring AT Commands with the LR1262 
Node Board. . . 
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Programming the LR1262 Node Board
4. Select the LR1262 Board:

• After installing the board package, go to Tools > Board > ... (expand the menu) and 
select the specific LR1262 board from the list (e.g., "RP2040").

5. Connect the Board:
Connect your LR1262 Node board to your computer using a USB cable.

6. Select the Port:
Go to Tools > Port and select the COM port that corresponds to your LR1262 
board.

7. Upload Code:
Open or create a sketch in the Arduino IDE.
Click the "Upload" button to compile and upload your code to the LR1262 board.

Lab: Exploring AT Commands with the LR1262 
Node Board. . . 
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AT_Command_LED
Indicator Code

Lab: Exploring AT Commands with the LR1262 
Node Board. . . 
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Lab: Exploring AT Commands with the LR1262 
Node Board. . . 

AT_Command_LED
Indicator Code
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Congratulations: The LED should turn on after the AT Command is entered in the 
Serial Monitor.

Lab: Exploring AT Commands with the LR1262 
Node Board. . . 

AT_Command_LED
Indicator Code
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Congratulations: The LED should turn on after the AT Command is entered in the 
Serial Monitor.

Lab: Exploring AT Commands with the LR1262 
Node Board. . . 

AT_Command_LED
Indicator Code: Entered 
AT Command, Output 
Response
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Congratulations: The LED should turn on after the AT Command is entered in the 
Serial Monitor.

Lab: Exploring AT Commands with the LR1262 
Node Board. . . 

AT_Command_LED
Indicator Code: Entered 
AT Command, Output 
Response
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Congratulations: The LED should turn on after the AT Command is entered in the 
Serial Monitor.

Lab: Exploring AT Commands with the LR1262 
Node Board. . . 

AT_Command_LED
Indicator Code: Entered 
AT Command, Output 
Response
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Question 5

In reviewing slide 34, which line of code blinks the 
LED?

a) 19
b) 14
c) 28
d) none of the above
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Thank you for attending
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Please consider the resources below:

Rahman, H.U., Ahmad, H., Ahmad, M., & Asif Habib, M. (2020). LoRaWAN: State of the art, challenges, 
protocols, and research issues. 
https://www.researchgate.net/publication/348637291_LoRaWAN_State_of_the_Art_Challenges_Protocols_an
d_Research_Issues.

Sani Danladi, M.& Baykara, M. (2022). Design and implementation of temperature and humidity monitoring 
system using lpwan technology. Ingenierie des Systemes d’Information, 27(4), 521-529. 
https://www.researchgate.net/publication/363810711_Design_and_Implementation_of_Temperature_and_Hum
idity_Monitoring_System_Using_LPWAN_Technology

Wilcher, D. (2025). Introduction to at commands. GitHub.https://github.com/DWilcher/DesignNews-
WebinarCode/blob/main/June_25_Webinar_Code.zip 
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