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Webinar Logistics

 Turn on your system sound to hear the streaming presentation.

« If you have technical problems, click “Help” or submit a question
asking for assistance.

- Participate in ‘Attendee Chat’ by maximizing the chat widget in your
dock.



Continuing
‘ ‘ Education
Center

Dr. Don Wilcher

Visit ‘Lecturer Profile’ in your console for more details.

LinkedIn Page:
https://www.linkedin.com/in/dr-don-wilcher-ed-d-mseit-ee-
ceta-2/35151/

Patreon Page:
https://www.patreon.com/c/DrDon683
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, Course Kit and Materials
Elecrow LR1302 LoRaWAN Pi Hat

Raspberry Pi 4 Single Board Computer USB-C Cable Elecrow Crowtail LED 2.0

LR1302 Gateway
Module

Elecrow LR1262 Node Board
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Research Perspective

« “LoRaWAN is one of the promising technologies of the Low Power
Wide Arena Network (LPWAN) that provides communication with
low power, low cost, long-range, and low data rate (Rahman et al.,
2020).”
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Agenda:

« Key Terms and Definitions

« Orthogonal Spreading Factor

« LoRaWAN Communication Protocol Stack

« Elecrow LoRaWAN Pi Hat and Node Board Overview
 Lab: Exploring the Elecrow LR1262 Node Board
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Key Terms and Definitions

Term

LoRaWAN

LoRa

Chirp Spread Spectrum
(CSS)

LPWAN (Low Power Wide
Area Network)

MAC Layer (Medium

Access Control)

Definition

A communication protocol and system architecture for wireless networks that uses LoRa
technology at the physical layer. Enables secure, bidirectional communication over long

distances with low power.

The physical layer modulation technique (based on Chirp Spread Spectrum) used in

LoRaWAN. It handles the actual transmission and reception of radio signals.

A modulation technique that spreads the signal over a wider frequency, improving

resistance to interference and enabling long-distance communication.

A wireless network type designed for low power consumption and long-range

communication, ideal for loT devices.

A network layer responsible for managing how data packets are transmitted and accessed

over the medium. In LoRaWAN, this includes device classes and duty cycling rules.
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Key Terms and Definitions. ..

Term

End Device

Gateway

Network Server

Application Server

Definition
An loT device that sends data to a gateway. These are often sensors or actuators using Class

A, B, or C configurations.

A relay device that forwards messages between end devices and the LoRaWAN network

server.

Central server that processes data from gateways, manages network functions, and enforces

security and routing policies.

Processes application-level data and often integrates with cloud platforms or user

interfaces.
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Question 1

What is LoRa?

a) The physical layer modulation technique(based
on Continuous Spread Spectrum) used in
LoRaWAN. -

b) The physical layer modulation technique (based on
Chirp Technology) used in LoRaWAN.

c) The physical layer modulation technique (based on
Chirp Spread Spectrum).

d) none of the above
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Key Terms and Definitions...
Chirp Spread Spectrum Signal
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Key Terms and Definitions...

" Upchirp and Downchirp in LoRa Communication

In LoRa (Long Range) technology, chirps are the fundamental building blocks of its modulation scheme
known as Chirp Spread Spectrum (CSS). These chirps are specialized signals where the frequency changes

over time. There are two types:

. Upchirp

* Anupchirp is a signal whose frequency increases linearly over time.

* |t starts at the lowest frequency in the band and ends at the highest.

» Used for data transmission in LoRa because upchirps are the default symbols for representing bits.

~ Example:

Think of a bird sound that starts low and sweeps up in pitch — that's an upchirp.

11
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Key Terms and Definitions...

./ Downchirp

* A downchirp is a signal whose frequency decreases linearly over time.

» |t starts at the highest frequency and sweeps down to the lowest.

» Primarily used for synchronization, de-spreading, and demodulation in the receiver.

S Example:
Imagine a siren that starts high and then drops in pitch — that's a downchirp.

12
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Key Terms and Definitions...

Upchirp and Downchirp Electronic Circuit Example

Daylight Bird or Early Bird:
Radio Shack Science Fair
150-In-1 Electronic Project
Kit
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Question 2

What approach is used as the fundamental building
blocks for LoRa modulation scheme?

a) End Device

b) Gateway

c) MAC Layer

d) Chirps

14
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Key Terms and Definitions...

=! Role in LoRa Modulation and Demodulation
LoRa encodes data using variations in the timing (phase offset) of upchirps.

» The receiver uses a downchirp to correlate and decode the upchirps.

e This upchirp/downchirp correlation allows for:
* High sensitivity (below noise floor)
* Robustness to interference

* Precise symbol timing

15
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Key Terms and Definitions...

Upchirp and Downchirp in Frequency vs. Time Domain
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Orthogonal Spreading Factor

LoRa uses Spreading Factors (SFs) as a way to encode data over a wider bandwidth, allowing it to transmit :
signals reliably over long distances with low power consumption. These spreading factors are orthogonal,

which is one of the reasons LoRa can support many devices in the same area without interference.

../ What is a Spreading Factor (SF)?
A Spreading Factor is the ratio between the symbol rate and chip rate in spread spectrum communication. In
LoRa, it determines:

* Duration of each symbol (time on air)

* Data rate (inversely proportional to SF)

* Sensitivity of the receiver (higher SF = better sensitivity)

LoRa supports SFs from SF7 to SF12.

17
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Orthogonal Spreading Factor ...

¢ Key Concept: Orthogonality

<= Orthogonal = Independent

* Orthogonal SFs allow multiple signals to coexist on the same frequency and bandwidth without

interfering with each other.

* A gateway can simultaneously decode multiple transmissions using different SFs—even if they overlap

in time and frequency.

18
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Orthogonal Spreading Factor ...

~~ Effects of Different SFs

Spreading Factor Range Data Rate Time on Air Power Use
SF7 Short High Low Low
SF12 Long Low High Higher

» SF7 is used when devices are close to the gateway and can afford higher speeds.

* SF12 is used for distant devices needing better signal sensitivity.

19
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Question 3

What is Spreading Factor?

a) The ratio between the symbol rate and flop rate in
spread spectrum communication.

b) The ratio between the modulation rate and chirp
rate in spread spectrum communication.

c) The ratio between the symbol rate and chirp rate
in spread spectrum communication.

d) none of the above

20
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Orthogonal Spreading Factor ...

@ Why Is Orthogonality Useful in LoRa?

More devices can share the same frequency.

Reduced collisions in data transmission.

<

Efficient use of spectrum.

Better network scalability.

21
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Orthogonal Spreading Factor...

@ Why Orthogonal SFs Matter

* Enables scalability in LoRaWAN networks.
* Helps maintain network reliability even as more devices are added.

» Supports adaptive data rate (ADR): nodes choose the best SF based on link quality.

22
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LoRaW AN Protocol Stack

~ LoRaWAN (LoRa Wide Area Network)

While LoRa handles the radio modulation, LoRaWAN is the protocol that defines how devices use LoRa to

communicate. It defines the MAC (Medium Access Control) layer.

[=] Protocol Stack:
LoRaWAN operates on a star topology, where:

* End Devices communicate only with gateways.

Gateways forward the data to a network server, which routes it to the appropriate application server.

+ Network Management:

Managed by the LoRa Alliance.

Supports secure bi-directional communication between devices and the cloud.

23
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LoRaW AN Protocol Stack...

User Define Application Layer
LoRa LoRaWAN Specification
Alliance
LoRa MAC

Rahman et al.,2020
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LoRaW AN Protocol Stack...

Antenna Antenna

\V4 V%
LoRaWAN Network

Architecture |
LR1302 Raspberry Pi
USB or SPI Internet [R1262
Concentrator Host ar
Intranet Mote
GPS
Pulse/sec NMEA
(PPS)
Gateway
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LoRaW AN Protocol Stack...

End Nodes Concentrator [ Gateway Network Server Application Server

LTE/LTE-M/ethernet

LoRa RF TCP/IP TLS1.2 TCP/IP TLS1.2
LoRaWAN LoRaWAN Secure Payload

AES Secured Payload

26
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Question 4

In reviewing slide 24, what level does the LoRaWAN
specification align with?

a) User Define

b) LoRa Alliance

c) LoRa-Semtech

d) none of the above

27
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LoRaW AN Protocol Stack...

Y Device Classes in LoRaWAN

There are three classes of end devices, optimized for different use cases:
Class Description Power Use Use Case

Class A Most energy-efficient. Devices sleep and wake only to Very low Battery-powered sensors

send data (uplink). A short window follows to receive

downlink.

Class B Allows scheduled receive windows in addition to Class A Moderate Semi-frequent control
behavior. Syncs to beacon signals for downlink applications
scheduling.

Class C Always listening (except when transmitting), enabling High Mains-powered actuators or
immediate downlink. controllers

28
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LoRaWAN Protocol Stack...
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Danladi & Baykara,2022
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Elecrow LoRaW AN Pi Hat and Node
Board Overview

%% Elecrow LR1302 LoRaWAN Pi Hat

« The Elecrow LR1302 is a high-performance LoRaWAN gateway
module.

« Designed to integrate seamlessly with Raspberry Pi models 3
through 5.

« |t features a standard Pi Hat form factor and is powered by the
Semtech SX1302 chipset.

a) Enabling 8-channel LoRaWAN communication.

b) Makes it suitable for applications requiring long-range, low-
power wireless connectivity.

30
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Elecrow LoRaW AN Pi Hat and Node
Board Overview...

% Elecrow LR1302 LoRaWAN Pi Hat _.i- 2

LR1302Gateway Module

Frequencies:
EU: 868MHz
US-915MHz

31




Elecrow LoRaW AN Pi Hat and Node
Board Overview...
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" Elecrow LR1262 Node Board

« The Elecrow LR1262 Node Board is a compact
and efficient LoRaWAN node module designed for
long-range communication in loT applications.

e |t combines the Raspberry Pi RP2040
microcontroller with the LR1262 LoRa module,

supporting both point-to-point and LoRaWAN
network communications.

32
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Elecrow LoRaW AN Pi Hat and Node
Board Overview...

Key Features:

* Microcontroller: Raspberry Pi RP2040 dual-core ARM Cortex-MO0+ processor running at 133 MHz, with
264KB SRAM and 4MB onboard flash memory.

* LoRa Module: Integrates the LR1262 module, supporting frequency bands from 803 MHz to 930 MHz,
covering regions like IN865, EU868, AU915, US915, KR920, RU864, and AS923.
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Elecrow LoRaW AN Pi Hat and Node
Board Overview...
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Elecrow LoRaW AN Pi Hat and Node
Board Overview...

Interfaces:

*1x USB-C interface for power and programming.

*6x 5V Crowtail interfaces: 2x analog, 2x digital, 1x

UART, 1x 12C.

«2x10 universal GPIO interfaces.

*1x battery interface.

*1x solar interface for charging.

Power Supply: Operates at 5V/1A via USB-C.

Dimensions: Compact size of 35mm x 50mm, suitable for embedded
applications.

‘Development Environment: Compatible with Arduino and MicroPython,
facilitating flexible development options. 5
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Lab: Exploring the Elecrow LR1262 Node Board. ..
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Participant Learning Objectives:
« Participants will learn to set up the LR1262 Node Board.

« Participants will learn to test and program the LR1262 Node
Board using the Arduino IDE.

« Participants will learn to verify the operation of the LR1262
Node Board with test code.

37
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Lab: Exploring the Elecrow LR1262 Node Board

Crowtails

—

Concept Diagram LED Crash Sensor

\

Top PCB
Elecrow LR1262

LoRaWAN Node
Module

RPi2040
Microcontroller

- —/
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Electronic Components
required for the LR1262
Node Board
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The attached £ S
components to SR\ S
the [R1262 |

Node Board
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Lab: Exploring the Elecrow LR1262 Node Board. ..

Programming the LR1262 Node Board

1. Install the Arduino IDE:
If you haven't already, download and install the Arduino IDE from the official Arduino website.

2. Add the LR1262 Board Package:
* Open the Arduino IDE.
» Go to File > Preferences.
* In the "Additional Boards Manager URLs" field, add the following
URL.:_https://github.com/earlephilhower/arduino-
pico/releases/download/global/package rp2040 _index.json (This URL is for the RP2040, which
is often associated with similar LoRa boards like the LR1262).
* Click "OK.
3. Install the Board Package:
* Go to Tools > Board > Boards Manager.
» Search for "RP2040" or a similar term related to the LR1262 board.
+ Install the board package, but avoid the latest version. It is recommended to choose version

2.6.0.

41
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Lab: Exploring the Elecrow LR1262 Node Board. ..
Programming the LR1262 Node Board

4. Select the LR1262 Board:

« After installing the board package, go to Tools > Board > ... (expand the menu) and
select the specific LR1262 board from the list (e.g., "RP2040").

5. Connect the Board:
Connect your LR1262 Node board to your computer using a USB cable.
6. Select the Port:
Go to Tools > Port and select the COM port that corresponds to your LR1262
board.
7. Upload Code:
Open or create a sketch in the Arduino IDE.
Click the "Upload" button to compile and upload your code to the LR1262 board.

42
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Lab: Exploring the Elecrow LR1262 Node Board. ..

void setup() {
pinMode (2, INPUT PULLUP) ;
pinMode (3, OUTPUT) ;

}

Switch_Light Code

Hvoid loop() {
] if (digitalRead(2) == LOW) {
digitalWrite (3, HIGH) ;
}
else{
digitalWrite (3, LOW) ;
-}
}
Congratulations: The LED should turn on when the Crash Sensor is pressed.

43
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Question 5

In reviewing slide 43, what type of digital logic switch
iIs being implemented in Line 7?

a) Positive Logic

b) Inverted Logic

c) Buffer

d) none of the above

44
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Assembled and /
Functional Switch-Light &=
RP2040 Device

Watch the Video Clip!
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Thank you for attending

Please consider the resources below:

Rahman, H.U., Ahmad, H., Ahmad, M., & Asif Habib, M. (2020). LoRaWAN: State of the art, challenges,

protocols, and research issues.
https://www.researchgate.net/publication/348637291 LoRaWAN_State of the Art Challenges Protocols_an

d_Research Issues.

Sani Danladi, M.& Baykara, M. (2022). Design and implementation of temperature and humidity monitoring
system using lpwan technology. Ingenierie des Systemes d’Information, 27(4), 521-529.
https://www.researchgate.net/publication/363810711 Design and Implementation_of Temperature and Hum

idity Monitoring_System Using LPWAN _Technology

Wilcher, D. (2025). Introduction to at commands. GitHub.https://github.com/DWilcher/DesignNews-
WebinarCode/blob/main/June 25 Webinar_Code.zip
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